Imagine Learning Classroom - Educators Cannot Create Assignments
Incident Report for Imagine Learning
Resolved
Our team has implemented a solution. Any assignment created this morning may need to be recreated.

Thank you for your patience.
Posted Sep 11, 2023 - 08:38 MST
Investigating
Our team is actively investigating an issue impacting users of products supported by the Imagine Learning Classroom.

Educators cannot create new assignments.

We apologize for the inconvenience and will provide an update soon.
Posted Sep 11, 2023 - 08:17 MST
This incident affected: Core Curriculum (Imagine Learning Illustrative Mathematics, Imagine Learning EL Education, Imagine Learning Guidebooks, Imagine Learning Odell Education).