Edgenuity SIS Issues with Modifying Enrollments
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted May 20, 2022 - 09:49 MST
Monitoring
We have identified an issue with the Edgenuity SIS which supports Imagine Instructional Services, Edgenuity Virtual Academy, Park City Independent, Ignitia Virtual Academy, and Giant Campus.

Educators may have experienced difficulty modifying enrollments, adding new enrollments, and changing the status of enrollments. A fix has been implemented and we are monitoring to ensure that customers are no longer impacted.

We apologize for the inconvenience and appreciate your patience.
Posted May 20, 2022 - 06:12 MST
This incident affected: Academies (Imagine Learning Excellence Academy, Giant Campus, Ignitia Virtual Academy, Park City Independent) and Virtual School Services (Imagine Instructional Services).