Imagine Edgenuity - Educators Cannot Log In
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Feb 27, 2024 - 17:09 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Feb 27, 2024 - 17:03 MST
Identified
Our team has identified the cause of the issue and are preparing to deploy a solution.

We will continue to update progress.
Posted Feb 27, 2024 - 17:00 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Edgenuity - as well as - Imagine MyPath Legacy and Imagine Purpose 6-12.

Educators are not able to log in to the application.

We apologize for the inconvenience and will provide an update soon.
Posted Feb 27, 2024 - 16:47 MST
This incident affected: Courseware (Imagine Edgenuity, Imagine EdgeEX) and Supplemental & Intervention (Imagine MyPath Legacy, Imagine Purpose 6-12).