Instructional Services and Academies - Carone Courses Unavailable

Incident Report for Imagine Learning

Resolved

We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Sep 16, 2025 - 14:06 MST

Investigating

We are receiving reports of an outage affecting Carone Fitness, our 3rd-party Physical Education and Health curriculum provider. This issue is currently impacting all Carone Fitness PE and Health courses.

Our team is actively monitoring the situation.

We apologize for the inconvenience and will share updates as we learn them.
Posted Sep 16, 2025 - 13:41 MST
This incident affected: Academies (Imagine Learning Excellence Academy, Giant Campus, Ignitia Virtual Academy, Park City Independent) and Virtual School Services (Imagine Instructional Services).