Imagine Edgenuity - Some Courses Have Incorrect Completion Times
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Mar 07, 2024 - 09:19 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Edgenuity.

We are aware that pacing and estimated remaining completion time for some courses are incorrect, due to inaccurate estimated completion times for some course activities. This does not impact students' abilities to continue working. We are working to fix the incorrect data now.
Posted Mar 07, 2024 - 08:29 MST
This incident affected: Courseware (Imagine Edgenuity) and Virtual School Services (Imagine Instructional Services).