Imagine Edgenuity Students and Educators Can Not Log In.
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted Jul 06, 2022 - 11:21 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 06, 2022 - 10:17 MST
Update
We are continuing to investigate this issue.
Posted Jul 06, 2022 - 10:12 MST
Update
We are continuing to investigate this issue.
Posted Jul 06, 2022 - 10:11 MST
Update
We are continuing to investigate this issue.
Posted Jul 06, 2022 - 10:00 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Edgenuity; as well as, Imagine MyPath Legacy and Imagine Purpose Prep 6-12 users who launch their experience from the Edgenuity LMS.

Students and Educators will not be able to log in. Teams are working to resolve.

We apologize for the inconvenience and will provide an update soon.
Posted Jul 06, 2022 - 09:59 MST
This incident affected: Courseware (Imagine Edgenuity), Academies (Imagine Learning Excellence Academy, Giant Campus, Ignitia Virtual Academy, Park City Independent), Virtual School Services (Imagine Instructional Services), and Supplemental & Intervention (Imagine MyPath Legacy, Imagine Purpose 6-12).