Imagine Language & Literacy - Some Students are Stuck after Completing the Beginning of Year Test
Incident Report for Imagine Learning
Resolved
The application is up and running. We will work directly on any isolated occurrences.

We apologize for the prior inconvenience.
Posted Aug 22, 2023 - 13:49 MST
Update
Our team has not yet identified the cause of the issue. We will continue to update progress.

Your patience is appreciated.
Posted Aug 22, 2023 - 12:37 MST
Investigating
Our team is actively investigating an issue impacting some students of Imagine Language & Literacy.

Some students cannot advance after completing the Beginning of the Year Test.

We apologize for the inconvenience and will provide an update soon.
Posted Aug 22, 2023 - 10:06 MST
This incident affected: Supplemental & Intervention (Imagine Language & Literacy).