Imagine Literacy Suite: Some Teachers and Administrators Cannot Log In
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Aug 09, 2023 - 14:08 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Aug 09, 2023 - 13:58 MST
Update
We are continuing to investigate. Thank you for your patience.
Posted Aug 09, 2023 - 12:57 MST
Update
Our team is actively investigating an issue that some teachers and administrators of Imagine Language & Literacy, Imagine Español, Imagine Reading, Imagine Lectura, and Imagine Galileo cannot log in. These users are redirected to a different product login page.

Your patience is appreciated.
Posted Aug 09, 2023 - 11:05 MST
Investigating
Our team is actively investigating an issue impacting Imagine Galileo. Teachers and administrators are presented an error message when attempting to log in.

We apologize for the inconvenience and will provide an update soon.
Posted Aug 09, 2023 - 10:22 MST
This incident affected: Supplemental & Intervention (Imagine Language & Literacy, Imagine Español, Imagine Lectura, Imagine Reading, Imagine Galileo).