Multiple Products - Teachers Real Time Reporting Behind
Incident Report for Imagine Learning
Resolved
We are happy to report that real time reporting has been restored.

We apologize for the prior inconvenience.
Posted Dec 18, 2024 - 20:12 MST
Investigating
Our team is actively investigating an issue impacting Teachers of several products.

Real time student progress is behind by about 2 hours.

We apologize for the inconvenience and will provide an update soon.
Posted Dec 18, 2024 - 19:01 MST
This incident affected: Supplemental & Intervention (Imagine MyPath K-12, Imagine Español, Imagine Lectura, Imagine Galileo, Imagine Purpose K-5, Imagine Math, Imagine Science Corner).