Imagine Math and Imagine Math Facts - Students Cannot Log in
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted May 19, 2023 - 00:38 MST
Investigating
Our team is actively investigating an issue impacting Imagine Math and Imagine Math Facts users. Students current cannot log in and are presented an error message.

We apologize for the inconvenience and will provide an update soon.
Posted May 19, 2023 - 00:14 MST
This incident affected: Supplemental & Intervention (Imagine Math, Imagine Math Facts).