Imagine Language & Literacy - Educators Cannot Open Reports
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume report activities without difficulty._
We apologize for the prior inconvenience.
Posted Jan 23, 2023 - 07:52 MST
Update
Our team is validating the report data. This verification process will continue until Monday morning. During this time, some reports may be slow to load.
Posted Jan 20, 2023 - 12:08 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Jan 20, 2023 - 10:17 MST
Identified
Our team is actively investigating an issue impacting educators using Imagine Language & Literacy. Educators cannot open reports.

We apologize for the inconvenience and will provide an update soon.
Posted Jan 20, 2023 - 10:09 MST
This incident affected: Supplemental & Intervention (Imagine Language & Literacy).