Imagine Edgenuity EdgeEX: Educators Cannot Use the Catalog, Students Cannot Load Activities
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted May 10, 2023 - 07:53 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted May 10, 2023 - 07:50 MST
Identified
Our team has identified the cause of the issue and are preparing to deploy a solution.

We will continue to update progress.
Posted May 10, 2023 - 07:46 MST
Investigating
Our team is actively investigating an issue impacting users EdgeEX. Educators cannot open the Catalog and Students are not able to load activities.
We apologize for the inconvenience and will provide an update soon.
Posted May 10, 2023 - 07:38 MST
This incident affected: Courseware (Imagine Edgenuity).