Imagine Edgenuity and Imagine EdgeEX - Explore Learning Gizmos Not Working

Incident Report for Imagine Learning

Resolved

We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Jul 01, 2025 - 10:40 MST

Update

We are continuing to investigate this issue.
Posted Jul 01, 2025 - 10:28 MST

Investigating

We are aware that Explore Learning Gizmos are currently not accessible and are actively working with Explore Learning to address the problem.
Posted Jul 01, 2025 - 10:27 MST
This incident affected: Courseware (Imagine Edgenuity, Imagine EdgeEX), Academies (Imagine Learning Excellence Academy, Giant Campus, Ignitia Virtual Academy, Park City Independent), and Virtual School Services (Imagine Instructional Services).