Imagine Edgenuity, Imagine EdgeEX - Educator Login and Slowness Issues

Incident Report for Imagine Learning

Resolved

We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Dec 11, 2025 - 10:54 MST

Monitoring

Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Dec 11, 2025 - 10:53 MST

Investigating

Our team is actively investigating the login issues and slowness impacting some educators on Imagine Edgenuity and Imagine EdgeEX.

Thank you for your patience—we’ll provide an update shortly.
Posted Dec 11, 2025 - 10:35 MST
This incident affected: Courseware (Imagine Edgenuity, Imagine EdgeEX).