Imagine MyPath K-12, Imagine Lectura, , Imagine Reading, Imagine Math Report Information Delayed
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Apr 10, 2023 - 21:48 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Apr 10, 2023 - 21:38 MST
Identified
Our team has identified the cause of the issue and are preparing to deploy a solution.

We will continue to update progress.
Posted Apr 10, 2023 - 20:45 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine MyPath K-12, Imagine Lectura, Imagine Reading, Imagine Math.

Educators will experience reports that may not reflect recent student activity.

We apologize for the inconvenience and will provide an update soon.
Posted Apr 10, 2023 - 19:07 MST
This incident affected: Supplemental & Intervention (Imagine MyPath K-12, Imagine Lectura, Imagine Reading, Imagine Math).