Some Educators experiencing intermittent slowness or errors
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Jun 02, 2022 - 07:52 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 01, 2022 - 09:06 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Edgenuity; as well as, Imagine MyPath Legacy and Imagine Purpose Prep 6-12 users who launch their experience from the Edgenuity LMS.

Educators might experience intermittent slowness or errors.

We apologize for the inconvenience and will provide an update soon.
Posted Jun 01, 2022 - 07:44 MST
This incident affected: Academies (Edgenuity Virtual Academy, Giant Campus, Ignitia Virtual Academy, Park City Independent), Virtual School Services (Imagine Instructional Services), Courseware (Imagine Edgenuity), and Supplemental & Intervention (Imagine MyPath Legacy, Imagine Purpose Prep 6-12).