Imagine Edgenuity Errors
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Feb 25, 2022 - 13:18 MST
Monitoring
Our team implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Feb 25, 2022 - 09:29 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Edgenuity; as well as, Imagine MyPath and Imagine Purpose Prep users who launch their experience from the Edgenuity LMS.

Students and Educators might be experiencing errors.

We apologize for the inconvenience and will provide an update soon.
Posted Feb 25, 2022 - 08:38 MST
This incident affected: Courseware (Imagine Edgenuity), Supplemental & Intervention (Imagine MyPath K-12, Imagine Purpose K-5), Academies (Imagine Learning Excellence Academy, Giant Campus, Ignitia Virtual Academy, Park City Independent), and Virtual School Services (Imagine Instructional Services).