Imagine Language and Literacy, Imagine Español, and Imagine Math Facts Experience Degraded
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Oct 21, 2022 - 10:35 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Oct 21, 2022 - 09:33 MST
Identified
Our team has identified the cause of the issue and are preparing a solution. We also have determined that this also affects users of Imagine Math Facts.

We will continue to update progress.
Posted Oct 21, 2022 - 09:09 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Language & Literacy and Imagine Español.

Students and Educators may experience errors using these products and may be prompted to re-authenticate.

We apologize for the inconvenience and will provide an update soon.
Posted Oct 21, 2022 - 08:53 MST
This incident affected: Supplemental & Intervention (Imagine Language & Literacy, Imagine Español, Imagine Math Facts).