Imagine Language & Literacy Reports out of date
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted Feb 06, 2023 - 10:14 MST
Identified
Our team is actively investigating an issue impacting users of Imagine Language and Literacy.

Educators may notice that reports are not up to date.

We apologize for the inconvenience and will provide an update soon.
Posted Feb 06, 2023 - 08:55 MST
This incident affected: Supplemental & Intervention (Imagine Language & Literacy).