Twig Science - Students and Educators cannot access elementary lesson content and Educators cannot access the navigation tool bar.
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted Jan 15, 2024 - 05:16 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 15, 2024 - 05:15 MST
Update
We are continuing to work on a fix for this issue.
Posted Jan 15, 2024 - 05:07 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 15, 2024 - 05:06 MST
Investigating
Our team is actively investigating an issue impacting users of Twig Science.

Students, Educators are unable to access lesson content and Educators are unable to access the navigation tool bar. Assessments are not affected.

We apologize for the inconvenience and will provide an update soon.
Posted Jan 15, 2024 - 04:59 MST
This incident affected: Core Curriculum (Twig Science).