Imagine Edgenuity Assessments not accessible for some students

Incident Report for Imagine Learning

Resolved

We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Jul 23, 2026 - 13:22 MST

Update

We are continuing to investigate this issue.
Posted Jul 23, 2026 - 12:00 MST

Update

Our team has not yet identified the cause of the issue on the Proctorio end. We will continue to update you on progress. For now, we are watching the Proctorio outage using an independent monitoring service: https://statusgator.com/services/proctorio

Your patience is appreciated.
Posted Jul 23, 2026 - 10:48 MST

Investigating

Our team is actively investigating an issue impacting users of Imagine Edgenuity.

Students using the Proctorio lockdown browser are down

Students in districts with the Proctorio lockdown browser enabled are unable to launch Quizzes, Tests, and Exams.

Proctorio will be updating its status page on this shortly: https://uptime.proctorio.com/
Posted Jul 23, 2026 - 09:28 MST
This incident affected: Courseware (Imagine Edgenuity, Imagine EdgeEX).