Errors when accessing AP World Language activities
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted Mar 10, 2022 - 10:48 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Edgenuity; as well as, Imagine MyPath Legacy and Imagine Purpose Prep 6-12 users who launch their experience from the Edgenuity LMS.

Students and Educators are receiving the error, “Oauth Error - Invalid Oauth credentials. Please contact your administrator.” when attempting to access activities in AP World Language courses.

We apologize for the inconvenience and will provide an update soon.
Posted Mar 10, 2022 - 09:43 MST
This incident affected: Courseware (Imagine Edgenuity), Academies (Imagine Learning Excellence Academy, Giant Campus, Ignitia Virtual Academy, Park City Independent), Virtual School Services (Imagine Instructional Services), and Supplemental & Intervention (Imagine MyPath Legacy, Imagine Purpose 6-12).