Reports Timeliness
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Sep 20, 2022 - 13:05 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Sep 20, 2022 - 12:19 MST
Investigating
Users of MyPath K-12, Imagine Math, Imagine Reading, and Imagine Lectura may see reports that do not reflect recent student activity.

We apologize for the inconvenience and will provide an update soon.
Posted Sep 20, 2022 - 12:14 MST
This incident affected: Supplemental & Intervention (Imagine MyPath K-12, Imagine Lectura, Imagine Reading, Imagine Math).