Imagine Edgenuity - Students Experiencing Errors in World Language Courses
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Dec 21, 2022 - 09:24 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Dec 21, 2022 - 08:31 MST
Update
Our team is actively investigating an issue impacting users of Imagine Edgenuity. Students and Educators may be experiencing errors while taking World Language Courses.
Posted Dec 21, 2022 - 08:18 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Edgenuity. Students and Educators may be experiencing errors while taking World Language Courses.

We apologize for the inconvenience and will provide an update soon.
Posted Dec 21, 2022 - 08:09 MST
This incident affected: Academies (Edgenuity Virtual Academy, Giant Campus, Ignitia Virtual Academy, Park City Independent), Courseware (Imagine Edgenuity), Virtual School Services (Imagine Instructional Services), and Supplemental & Intervention (Imagine MyPath Legacy, Imagine Purpose Prep 6-12).