Imagine Math & Imagine Math Facts

Incident Report for Imagine Learning

Resolved

This incident has been resolved.
Posted Feb 07, 2022 - 12:56 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 07, 2022 - 10:32 MST

Identified

Our team is actively investigating an issue impacting users of Imagine Math & Imagine Math Facts.

Users of the Usage, Benchmark, Mastery, Student Progress Report, and Student Data Export are experiencing a temporary lag in data reporting causing discrepancies in some fields.

We apologize for the inconvenience and will provide an update soon.
Posted Feb 07, 2022 - 09:46 MST
This incident affected: Supplemental & Intervention (Imagine Math, Imagine Math Facts).