Imagine Math and Imagine Español Reports not up to date
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Sep 28, 2023 - 09:49 MST
Update
We are continuing to work on a fix for this issue.
Posted Sep 28, 2023 - 08:50 MST
Identified
Our team is actively investigating an issue impacting users of Imagine Math and Imagine Español.

Reports do not reflect recent student activity.

Our team has identified the cause of the issue and are preparing to deploy a solution.
Posted Sep 28, 2023 - 08:50 MST
This incident affected: Supplemental & Intervention (Imagine Español, Imagine Math, Imagine Math Facts).