We are happy to report that users should now be able to resume activities without difficulty.
We apologize for the prior inconvenience.
Posted 12 days ago. Mar 19, 2025 - 10:06 MST
Monitoring
Our cloud provider has implemented a solution, and we are actively monitoring to ensure no further issues.
Thank you for your patience.
Posted 12 days ago. Mar 19, 2025 - 09:15 MST
Investigating
Our team is actively investigating an issue impacting users of products supported by the Imagine Learning Classroom.
1Educators are not able to reach the grading view as questions are showing the unattempted status in the application for educators. There is no impact to students.
Also, educators and authors are not able to select / update the exiting questions. They can create a new questions.
We apologize for the inconvenience and will provide an update soon.
Posted 12 days ago. Mar 19, 2025 - 04:55 MST
This incident affected: Core Curriculum (Imagine Learning Illustrative Mathematics, Imagine Learning EL Education, Imagine Learning Guidebooks, Imagine Learning Odell Education).