IL Classroom and EdgeEx - Activities Loading Slow
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Aug 14, 2024 - 09:55 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Aug 13, 2024 - 08:54 MST
Identified
We have seen return of the condition for slow loading. We are working to identify a solution.

We will continue to update progress.
Posted Aug 13, 2024 - 08:13 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Aug 13, 2024 - 08:08 MST
Identified
Our team has identified the cause of the issue and are preparing to deploy a solution.

We will continue to update progress.
Posted Aug 13, 2024 - 08:02 MST
Investigating
Our team is actively investigating an issue impacting users of EdgeEX and IL Classroom applications.

All activities in IL Classroom are loading slowly for students. Auto grading of submitted activities is delayed. The Teacher assignment report loads slowly or times out. Authors have intermittent issues authoring and saving edits.

Some Imagine EdgeEX activities, such as Short Writing are loading slowly for Students and Educators.

We apologize for the inconvenience and will provide an update soon.
Posted Aug 13, 2024 - 07:53 MST
This incident affected: Core Curriculum (Imagine Learning Illustrative Mathematics, Imagine Learning EL Education, Imagine Learning Guidebooks, Imagine Learning Odell Education) and Courseware (Imagine EdgeEX).