Imagine Language and Literacy, Imagine Español are having student access issues.
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted Mar 19, 2022 - 12:45 MST
Update
We are actively working with our cloud service provider to address this issue. The platform is currently fully operational for students and educators.
Thank you for your patience as we work to resolve this issue.
Posted Mar 18, 2022 - 14:28 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 18, 2022 - 09:28 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 18, 2022 - 09:21 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Language and Literacy and Imagine Español.

Students are experiencing intermittent errors loading activities.

We apologize for the inconvenience and will provide an update soon.
Posted Mar 18, 2022 - 09:05 MST
This incident affected: Supplemental & Intervention (Imagine Language & Literacy, Imagine Español).