Imagine Math, Imagine Math Facts, and Imagine Español: Usage, Progress, Benchmark, and Standards Reports Do Not Reflect Current Data
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Aug 03, 2023 - 17:55 MST
Identified
We are partnering with our vendor for a solution.
Posted Aug 03, 2023 - 16:41 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Math, Imagine Math Facts, and Imagine Español. The Usage, Progress, Benchmark, and Standards reports do not reflect current data. The cause has been identified and related to a third-party vendor.

We are coordinating with our vendor partner and will update soon.
Posted Aug 03, 2023 - 16:40 MST
This incident affected: Supplemental & Intervention (Imagine Español, Imagine Math, Imagine Math Facts).