Global AWS Outage Impacting Multiple Products and Features

Incident Report for Imagine Learning

Resolved

We have confirmed with our third-party vendors that all systems are operating normally. Users may now resume activities without issue.
Posted Oct 20, 2025 - 17:09 MST

Investigating

We are aware of the global AWS outage currently affecting multiple technology platforms. While Imagine Learning’s core platforms remain stable and fully operational, some third-party tools that integrate with our products — including ClassLink, Clever, and certain assessment services — may experience intermittent disruptions.

We are monitoring the situation closely and will post updates here if anything changes.

Thank you for your patience as we navigate this broader cloud infrastructure issue.
Posted Oct 20, 2025 - 09:44 MST
This incident affected: Courseware (Imagine Edgenuity, Imagine EdgeEX, Imagine Odysseyware), Supplemental & Intervention (Imagine MyPath K-12, Imagine Purpose K-5, Imagine+ Assessment), and Virtual School Services (Imagine Instructional Services).