Imagine Espanol, Language and Literacy - Some students may experience slowness and errors
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted Dec 02, 2024 - 10:33 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 02, 2024 - 10:28 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 02, 2024 - 08:07 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Espanol and Imagine Language and Literacy.

Some students are experiencing slowness and errors.

We apologize for the inconvenience and will provide an update soon.
Posted Dec 02, 2024 - 07:50 MST
This incident affected: Supplemental & Intervention (Imagine Language & Literacy, Imagine Español).