Support phone lines are down. Please chat or email us!
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted Mar 22, 2022 - 11:25 MST
Monitoring
ZenDesk is experiencing an outage with their phone system. This affects all customers trying to reach us by phone. Please reach out for support using our chat feature or by email. https://www.imaginelearning.com/en/us/support/customer-support#customer-support-contact-us
Posted Mar 22, 2022 - 10:00 MST
This incident affected: Virtual School Services (Imagine Instructional Services), Courseware (Imagine Edgenuity, Imagine Odysseyware), Core Curriculum (Imagine Learning Illustrative Mathematics, Imagine Learning EL Education, Imagine Learning Guidebooks, Imagine Learning Odell Education, Imagine Learning Twig Science, LearnZillion (Imagine Learning Classroom)), Supplemental & Intervention (Imagine MyPath K-12, Imagine Language & Literacy, Imagine Español, Imagine Lectura, Imagine Reading, Imagine Galileo, Imagine Purpose Prep K-5, Imagine Math, Imagine Math Facts, Imagine Pathblazer, Imagine Learning Robotify, Imagine MyPath Legacy, Imagine Purpose Prep 6-12), and Academies (Edgenuity Virtual Academy, Odysseyware Academy, Giant Campus, Ignitia Virtual Academy, Park City Independent).