Instructional Services and Some Academies - Teachers Cannot Sign into Buss LMS from Genius
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Oct 04, 2024 - 09:49 MST
Identified
Instructional Services and Academy Teachers cannot sign in to Buzz LMS from Genius. The cause has been identified, and a fix is planned to be deployed soon.

We apologize for the inconvenience and will provide an update soon.
Posted Oct 04, 2024 - 09:19 MST
This incident affected: Academies (Imagine Learning Excellence Academy, Giant Campus, Ignitia Virtual Academy) and Virtual School Services (Imagine Instructional Services).