Multiple Products - Progress, Usage, and Benchmark Reports Not Current
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Aug 15, 2023 - 11:03 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 15, 2023 - 10:10 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Reading, Imagine Lectura, Imagine MyPath, Imagine Purpose, and Imagine Science Corner.

Reporting for Progress, Usage, and Benchmark are not current and have delayed data.

We apologize for the inconvenience and will provide an update soon.
Posted Aug 15, 2023 - 10:00 MST
This incident affected: Supplemental & Intervention (Imagine MyPath K-12, Imagine Lectura, Imagine Reading, Imagine Purpose K-5, Imagine Science Corner).