Multiple Products - Issues Logging In and Navigation

Incident Report for Imagine Learning

Monitoring

Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Mar 26, 2026 - 09:28 MST

Identified

Our team is actively preparing a fix for an issue preventing some users from logging in, seeing errors when navigating the system, missing essay scores, and slowness.
Posted Mar 26, 2026 - 06:23 MST
This incident affects: Supplemental & Intervention (Imagine MyPath K-12, Imagine Language & Literacy, Imagine Español, Imagine Galileo, Imagine Purpose K-5, Imagine Math, Imagine Math Facts, Imagine+ Assessment), Core Curriculum (Dragonfly, Traverse), and Courseware (Imagine EdgeEX).