Imagine Learning products - Incident affecting multiple products

Incident Report for Imagine Learning

Resolved

This incident has been resolved.
Posted Aug 19, 2025 - 08:20 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 19, 2025 - 08:11 MST

Investigating

Our team is actively investigating an issue impacting users of multiple Imagine Learning products.

Users are able to login, but clicking on a product on the product portal page fails to launch other products.

We apologize for the inconvenience and will provide an update soon.
Posted Aug 19, 2025 - 07:58 MST
This incident affected: Supplemental & Intervention (Imagine MyPath K-12, Imagine Language & Literacy, Imagine Español, Imagine Galileo, Imagine Purpose K-5, Imagine Science Corner, Imagine+ Assessment) and Core Curriculum (Traverse).