Imagine EdgeEX - Students and Educators unable to access courses

Incident Report for Imagine Learning

Resolved

Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Aug 25, 2025 - 17:09 MST

Monitoring

Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Aug 25, 2025 - 16:50 MST

Investigating

Our team is actively investigating an issue impacting users of Imagine EdgeEX.

Students and Educators cannot access courses and may receive intermittent errors.

We apologize for the inconvenience and will provide an update soon.
Posted Aug 25, 2025 - 16:32 MST
This incident affected: Courseware (Imagine EdgeEX).