Multiple Products - Intermittent Issues Loading Content
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Dec 13, 2023 - 11:49 MST
Update
Some functionality has been restored for the IL Classroom products; however, users may still experience issues when attempting to access lesson plans and assignments.
Posted Dec 13, 2023 - 11:10 MST
Update
The IL Classroom products are more severely impacted by our vendor incident. Students and teachers may not be able use IL Classroom products.
Posted Dec 13, 2023 - 08:43 MST
Update
We are continuing to work on a fix for this issue.
Posted Dec 13, 2023 - 08:32 MST
Update
We are continuing to work on a fix for this issue.
Posted Dec 13, 2023 - 07:58 MST
Update
We are continuing to work on a fix for this issue.
Posted Dec 13, 2023 - 07:52 MST
Identified
Our team is actively investigating an issue impacting users of multiple products. A vendor partner is experience an incident impacting student and teachers. Some course content may not load intermittently. Users can refresh to restore their experience.

We apologize for the inconvenience and will provide an update soon.
Posted Dec 13, 2023 - 07:51 MST
This incident affected: Core Curriculum (Imagine Learning Illustrative Mathematics, Imagine Learning EL Education, Imagine Learning Guidebooks, Imagine Learning Odell Education), Courseware (Imagine Edgenuity, Imagine EdgeEX, Imagine Odysseyware), and Supplemental & Intervention (Imagine MyPath K-12, Imagine Lectura, Imagine Reading, Imagine Purpose K-5, Imagine Science Corner).