Imagine Language & Literacy and Imagine Español - Some Students Experiencing Errors
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted May 30, 2023 - 06:26 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted May 30, 2023 - 06:22 MST
Identified
Our team has identified the cause of the issue and are preparing to deploy a solution.

We will continue to update progress.
Posted May 30, 2023 - 05:53 MST
Investigating
Our team is actively investigating an issue impacting some students of Imagine Language & Literacy and Imagine Español. Some students may be experiencing long load time for pages or a something went wrong message and need to log back in.

We apologize for the inconvenience and will provide an update soon.
Posted May 30, 2023 - 05:50 MST
This incident affected: Supplemental & Intervention (Imagine Language & Literacy, Imagine Español).