Corporate Website Unavailable
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Sep 11, 2024 - 10:14 MST
Monitoring
Our third party vendor has restored service and imaginelearning.com is loading.

Thank you for your patience.
Posted Sep 11, 2024 - 09:56 MST
Investigating
Our team is actively investigating the corporate website www.imaginelearning.com, which is unavailable.

Users attempting to open www.imaginelearning.com see an error message.

Direct login to products:
- Imagine Edgenuity: https://auth.edgenuity.com/Login
- Imagine Learning Language Literacy, Reading, Lectura, Español: https://api.imaginelearning.com/signin
- Imagine Math: https://math.imaginelearning.com/users/sign_in
- Robotify: edu.robotify.com
- IL Classroom: https://ilclassroom.com/
- Traverse: https://api.imaginelearning.com/signin

Direct link to Support/Help:
https://help.imaginelearning.com/hc/en-us

We apologize for the inconvenience and will provide an update soon.
Posted Sep 11, 2024 - 09:26 MST