Imagine Language & Literacy Reports Out-of-Date
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Apr 05, 2022 - 09:11 MST
Monitoring
Imagine Language & Literacy is in a degraded state for educators. The platform is usable by educators and students. However, some reports may be out-of-date. We have identified the issue and the reports are updating so they will no longer out-of-date. We apologize for the inconvenience.
Posted Mar 31, 2022 - 11:43 MST
Investigating
Imagine Language & Literacy is in a degraded state for educators. The platform is usable by educators and students. However, some reports may be out-of-date. We're currently engaged and investigating the issue. We apologize for the inconvenience.
Posted Mar 31, 2022 - 11:08 MST
This incident affected: Supplemental & Intervention (Imagine Language & Literacy).