Imagine Edgenuity and Imagine EdgeEX - Administrators Reports Not Loading

Incident Report for Imagine Learning

Resolved

We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Jan 09, 2026 - 07:16 MST

Investigating

Our team is actively investigating an issue causing Administrator Reports to not load in Imagine Edgenuity and Imagine EdgeEX.

We apologize for the inconvenience and will provide an update as soon as possible.
Posted Jan 09, 2026 - 06:47 MST
This incident affected: Courseware (Imagine Edgenuity, Imagine EdgeEX).