Imagine Español and Imagine Language & Literacy - Students may be experiencing slow response times
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Aug 23, 2024 - 12:56 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Aug 23, 2024 - 06:40 MST
Identified
Our team has identified the cause of the issue and are preparing to deploy a solution.

We will continue to update progress.
Posted Aug 23, 2024 - 06:15 MST
Update
We are continuing to investigate this issue.
Posted Aug 23, 2024 - 06:04 MST
Investigating
Our team is actively investigating an issue impacting Students of Imagine Español and Imagine Language & Literacy.

Users may be experiencing slow page loads and response times.

We apologize for the inconvenience and will provide an update soon.
Posted Aug 23, 2024 - 06:03 MST
This incident affected: Supplemental & Intervention (Imagine Language & Literacy, Imagine Español).