Imagine MyPath K-12, Imagine Lectura, and Imagine Reading reports out of date.
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Mar 25, 2022 - 13:34 MST
Update
We are continuing to monitor the processing of reports.
Posted Mar 25, 2022 - 09:55 MST
Identified
Our team has identified an issue impacting users of Imagine MyPath K-12, Imagine Lectura, and Imagine Reading.

Educators may notice a delay in student activity appearing in the reports.

We apologize for the inconvenience and will provide an update soon.
Posted Mar 25, 2022 - 08:45 MST
This incident affected: Supplemental & Intervention (Imagine MyPath K-12, Imagine Lectura, Imagine Reading).