Twig Science Elementary - Students See and Error On Dashboard
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Oct 29, 2024 - 10:17 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Oct 29, 2024 - 10:03 MST
Investigating
Our team is actively investigating an issue impacting users of Twig Science Elementary.

Students with lessons see an error message when loading the dashboard.

We apologize for the inconvenience and will provide an update soon.
Posted Oct 29, 2024 - 08:45 MST
This incident affected: Core Curriculum (Twig Science).