Imagine EdgeEX - Students and Educators in EdgeEX will experience errors when accessing EdgeEX content

Incident Report for Imagine Learning

Resolved

We are happy to report that users should now be able to resume activities without difficulty.
Posted Feb 23, 2026 - 04:30 MST

Monitoring

We implemented a fix for Imagine EdgeEX content. We are monitoring the system currently.
Posted Feb 23, 2026 - 04:01 MST

Identified

We are deploying a fix for the Imagine EdgeEX content issues.
Posted Feb 23, 2026 - 03:30 MST

Investigating

Our team is actively investigating an issue affecting Students and Educators using Imagine EdgeEX.

We apologize for the inconvenience and will provide an update soon.
Posted Feb 23, 2026 - 03:23 MST
This incident affected: Courseware (Imagine EdgeEX).