Imagine Learning Classroom - Users Cannot Log In or Use Applications

Incident Report for Imagine Learning

Monitoring

Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Sep 14, 2026 - 11:06 MST

Identified

Some users are still experience issues. We are continuing to investigate.

We will continue to update progress.
Posted Sep 14, 2026 - 10:54 MST

Monitoring

Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Sep 14, 2026 - 10:43 MST

Investigating

Our team is actively investigating an issue impacting users of products supported by the Imagine Learning Classroom.

Users see an error message when they attempt log in or use the IL Classroom applications.

We apologize for the inconvenience and will provide an update soon.
Posted Sep 14, 2026 - 10:37 MST
This incident affects: Core Curriculum (Imagine Learning EL Education, Imagine Learning Guidebooks, Imagine Learning Illustrative Mathematics, Imagine Learning Odell Education).