Imagine Edgenuity - Students and educators in some districts may be experiencing errors reaching pages in Imagine Edgenuity
Incident Report for Imagine Learning
Resolved
This incident has been resolved.
Posted Sep 15, 2022 - 13:20 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 15, 2022 - 07:52 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Edgenuity.

Students and educators in some districts may be experiencing errors reaching pages in Imagine Edgenuity.

We apologize for the inconvenience and will provide an update soon.
Posted Sep 15, 2022 - 07:47 MST
This incident affected: Courseware (Imagine Edgenuity), Academies (Imagine Learning Excellence Academy, Giant Campus, Ignitia Virtual Academy, Park City Independent), Virtual School Services (Imagine Instructional Services), and Supplemental & Intervention (Imagine MyPath Legacy, Imagine Purpose 6-12).