Imagine Math is Unavailable to Students and Educators
Incident Report for Imagine Learning
Resolved
We are happy to report that users should now be able to resume activities without difficulty.

We apologize for the prior inconvenience.
Posted Aug 23, 2022 - 20:27 MST
Monitoring
Our team has implemented a solution, and we are actively monitoring to ensure no further issues.

Thank you for your patience.
Posted Aug 23, 2022 - 18:34 MST
Identified
Our team has identified the cause of the issue and are preparing to deploy a solution.

We will continue to update progress.
Posted Aug 23, 2022 - 18:07 MST
Update
Our team is still investigating the cause of the issue.

Thank you for your continued patience.
Posted Aug 23, 2022 - 14:32 MST
Update
Our team has not yet identified the cause of the issue. We will continue to update progress.

Your patience is appreciated.
Posted Aug 23, 2022 - 13:14 MST
Update
We are continuing to investigate this issue.
Posted Aug 23, 2022 - 12:33 MST
Update
We are continuing to investigate this issue.
Posted Aug 23, 2022 - 12:33 MST
Investigating
Our team is actively investigating an issue impacting users of Imagine Math and Imagine Math Facts.

Students and Educators are not able to login to Imagine Math and Imagine Math Facts.

We apologize for the inconvenience and will provide an update soon.
Posted Aug 23, 2022 - 12:26 MST
This incident affected: Supplemental & Intervention (Imagine Math, Imagine Math Facts).